Zuverlässigkeit eingebaut

Willkommen bei Geeklog
Donnerstag, 23. März 2017, 07:08 Uhr


 Alle Foren > Geeklog > Support Neues Thema Antwort schreiben
 Fehler wegen PHP Version?
 |  Druckfähige Version
RonnieR
 Mai 08 2013 10:38  (7506 Mal gelesen)  
Forum Veteran
Veteran

Status: offline

Mitglied seit: 09/19/03
Beiträge: 237

Hallo,
ich bekomme sein Gestern folgenden Fehler: "error selecting database".
Bin bei 1und1.
Kann es sein, dass dies mit PHP5 zusammenhängt?
Ich habe noch die GL Version 1.5.1
Zurückschalten im 1und1 ControlCenter auf PHP4 bringt nichts...

Gruss
Ronnie


 
Profil E-Mail
Zitat
Markus
 Mai 08 2013 10:45   
Forum Moderator
Moderator

Status: offline

Mitglied seit: 08/04/03
Beiträge: 1001

Bei plötzlich auftretenden Fehlern würde ich immer erst den Hoster fragen, was der geändert hat. Schreib den doch mal an!


 
Profil E-Mail Website
Zitat
RonnieR
 Mai 08 2013 10:51   
Forum Veteran
Veteran

Status: offline

Mitglied seit: 09/19/03
Beiträge: 237

OK
danke


 
Profil E-Mail
Zitat
Dirk
 Mai 08 2013 11:06   
Forum Admin
Admin

Status: offline

Mitglied seit: 03/29/02
Beiträge: 2132

Wie die Fehlermeldung ja schon andeutet würde ich auch eher in Richtung Datenbank gucken: Datenbank-Server geändert? Stimmen die Zugangsdaten, etc.

Mit PHP sollte das eigentlich nichts zu tun haben. Wenn es da ein Problem gäbe würde das andere Fehlermeldungen geben.

bye, Dirk


 
Profil E-Mail Website
Zitat
Markus
 Mai 08 2013 12:03   
Forum Moderator
Moderator

Status: offline

Mitglied seit: 08/04/03
Beiträge: 1001

Ich hatte den Fehler mal gegoogelt und auch ins Hilfecenter geschaut:
http://hilfe-center.1und1.de/ aber kein Ergebnis.


 
Profil E-Mail Website
Zitat
Dirk
 Mai 08 2013 12:08   
Forum Admin
Admin

Status: offline

Mitglied seit: 03/29/02
Beiträge: 2132

Die Meldung kommt ja auch von Geeklog Mr. Green

// Set the database
@mysql_select_db($this->_name) or die('error selecting database');


bye, Dirk


 
Profil E-Mail Website
Zitat
RonnieR
 Mai 08 2013 12:54   
Forum Veteran
Veteran

Status: offline

Mitglied seit: 09/19/03
Beiträge: 237

Hmm,
ich tippe trotzdem auf die PHP Version.
1und1 hat zum 1.05.2013 die PHP 4 abgeschaltet!
Preisfrageist, wie ich jetzt möglichst easy meine "alten" Seiten auf die neue GL Version mit PHP 5 Kompatibilität hochziehe... Aber da war mal was...
Mist, gerade jetzt, wo die Zeit eh knapp ist.
siehe www.ronnie-rigl.de

Der Oberhammer ist ja der:
Was passiert mit den alten MySQL 4-Datenbanken nach dem in der E-Mail mitgeteilten Abschaltdatum?
Die alte MySQL 4-Datenbank wird zum kommunizierten Abschaltdatum gelöscht. Auf die darin gespeicherten Daten kann dann nicht mehr zugegriffen werden. Bitte sorgen Sie daher frühzeitig für eine Sicherung der Daten.

Gruss
Ronnie


 
Profil E-Mail
Zitat
RonnieR
 Mai 08 2013 13:04   
Forum Veteran
Veteran

Status: offline

Mitglied seit: 09/19/03
Beiträge: 237

So,
und noch ne Info.
"MySQL-Datenbanken mit der Version 4.0 wurden wie angekündigt gesperrt. Sie haben die Möglichkeit, Ihre MySQL4.0-Datenbaken für 14 Tage zu bearbeiten, indem Sie auf "Entsperren" klicken. Sichern Sie in dieser Zeit Ihre MySQL4.0-Datenbanken mit phpMyAdmin und legen Sie eine neue MySQL5-Datenbank an."
Vielleicht hilft es dem ein oder anderen.
ich wiessnun was ich morgen mache... :-/

Ronnie


 
Profil E-Mail
Zitat
Dirk
 Mai 08 2013 13:13   
Forum Admin
Admin

Status: offline

Mitglied seit: 03/29/02
Beiträge: 2132

Passt aber doch zu dem, was ich geschrieben habe: Sie haben die MySQL 4-Datenbank abgeschaltet. Daraufhin hat Geeklog keine Verbindung mehr dazu aufbauen können (logisch) und die oben zitierte Meldung ausgeworfen.

Eigentlich solltest Du einfach Deine alte Datenbank aus MySQL 4 exportieren und in eine MySQL 5-Datenbank importieren können. Dann die Zugangsdaten in der db-config.php anpassen und die Site sollte wieder laufen.

bye, Dirk


 
Profil E-Mail Website
Zitat
RonnieR
 Mai 09 2013 02:59   
Forum Veteran
Veteran

Status: offline

Mitglied seit: 09/19/03
Beiträge: 237

So,
ich habe jetzt 5 Stunden experimentiert...
Ohne Erfolg.
Alte DB reaktiviert.
DB gesichert
Neue SQL DB (mitPHP5) angelegt,
Versuch den alten DB Export in neue DB zu importieren.

Import bietet Onlinetool von 1und1 nicht an, also phMyAdmin auf meiner Website installiert.
Import versucht --> permanenter Abbruch, egal ob die Backupdatei vom PC (timeout), oder vom Backup- Pfad online geladen wird --> Fehler:"Es wurden keinen Daten zum Importieren empfangen. Entweder wurde keine Datei ausgewählt, oder die Dateigröße hat die maximal erlaubte Größe der PHP-Konfiguration überschritten. Siehe FAQ 1.16."
Die Datei ist 2,3 MB gross!

Wenn ich die Installation von Geeklog als Neuinstallation mit der neuen DB mache, dann geht es.
Ich bekomme nur meine Daten nicht mehr rein :-/

Für Heute mache ich Schluss...

G
RR


 
Profil E-Mail
Zitat
Erzeugt in 0,54 Sekunden
Neues Thema Antwort schreiben



 Zeitzone: CET. Es ist jetzt 07:08 Uhr.
Normales Thema Normales Thema
Thema geschlossen Thema geschlossen
Wichtiges Thema Wichtiges Thema
Neuer Beitrag Neuer Beitrag
Wichtiges Thema mit neuen Beiträgen Wichtiges Thema mit neuen Beiträgen
Geschlossenes Thema mit neuen Beiträgen Geschlossenes Thema mit neuen Beiträgen
Beiträge von Gästen 
Schreiben erlaubt 
Gefiltertes HTML erlaubt 
Beiträge "entschärfen"